The other day I was installing a new ColdFusion 10 server on Windows 2008 Server for one of our clients at CFWebtools. This is a "Standard" license install so during the setup I chose to configure "All Sites for IIS" and thats when I ran into this error "Cannot configure IIS connector. Enable the required options ASP.NET, ISAPI Extensions and ISAPI Filter in IIS 7.5 under Windows Features and try again." After checking the IIS 7.5 features I found that those IIS feature were in fact installed. I tried several times and continued to get the same error.

I had to research this issue and didn't find anyone talking about this error, thus this blog post. I found what I needed in the Adobe ColdFusion 10 install documentation. (When all else fails read the instructions?) The IIS 7.5 feature CGI also need to be enabled. Well hey, it would be nice if the error message mentioned that one too!

It turns out there is already a bug report filed for this and Adobe claims it is fixed. However, the problem does persist because Adobe needs to change the actual file that you download. A "patch" after the fact is pointless when trying to fix an installation bug. And this bug is really just an "Error Message" that is incomplete. Enabling CGI in IIS 7.5 allows you to complete the installation.

I hope this short post saves someone time and hassle.